Installing Netbeans IDE in Vista

Tips

This is a solution to an issue encountered while installing Netbeans IDE in Windows Vista.

First you should have the JDK and JRE versions required by the version of Netbeans you are going to install. You can download them <here>.

While trying to run the Netbeans installer in Vista, many have reported the popup of the following error :

The installer is unable to run in graphical mode. Try running the installer with the -console or -silent flag.

The solution is simple.

Right click the Netbean installer file, choose Properties and under the “Compatibility” tab  uncheck the option ” Run this program in compatibility mode for :……“.

Next in the same window and same “Compatibility“, click on  the button “Show settings for all users“. In the Window that popups, disable/uncheck the option ” Run this program in compatibility mode for :…… “.

Click ok .

Thats all ! Now try running the Netbean installer  and it installs smoothly 🙂

note : This is a solution to the problem of installing Netbeans 5.5.1 version in Vista. I hope this helps for other versions too .

Update:

I met with success in installing even later versions of Netbeans,  in Windows 7, by following the tips above.

Additional links :

Advertisements

5 comments on “Installing Netbeans IDE in Vista

  1. I need help to install NetBeans on windows 7. I tried those tips but the option ” Run this program in compatibility mode for :……“. to unchecked is not shaded.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s